7 komentáře “Reportáž z GeeCON 2012

  1. Zpětný odkaz: » Šestý rok Myšlenek dne otce Fura Myšlenky dne otce Fura

  2. Diky Honzo za reportaz. Osobne me to privedlo na nekolik myslenek. * Clien/Server prenositelne jazyky (IMHO to je takova metafora)
    * Odepsani Scaly
    * Testy (should vs test). Ja osobne bych nevidel zasadni rozdil v should a test, ale spise v tom, ze testovaci metoda by mela mit komplexni nazev, ze ktereho bude patrne co testujeme napr testWithdrawMoneyMonthlyLimitReached

    • Ad myšlenky:

      1) zdá se mi, že nápad NodeJS variabilně migrovat kód mezi serverem a klientem padl docela na úrodnou půdu, co vidím ale jako problém je generovaný JavaScript na klientovi – pokud to bude nějaká hrůza, jakou generuje GWT moc velkou budoucnost tomu neprorokuji – NodeJS tady vítězí především tím, že klient je stejně dobře debugovatelný jako server, protože to je kód, který je více méně odpovídá tomu, co napsal vývojář. Cesta vytyčená GWT se skutečně moc neosvědčila – někde jsem dokonce zaslechl, že i sám velký Google od GWT pomalu ustupuje a migruje své projekty na jiné řešení. Kdo ví, jestli se třeba za rok nedočkáme ukončení podpory projektu …

      2) osobně mám taky ten pocit, že Scala svůj boj s mainstreamem pomaličku prohrává – nicméně na jejích ramenech se evidentně staví. Řekl bych, že tady ještě pár let nebude úplně rozhodnuto, ale ta komplexita Scaly je asi zároveň její oprátkou

      3) to should skutečně navádí k lepšímu pojmenovávání testů (IMHO), slovo test se spojuje s podnětem, kdežto should se slovesem -> použití slovesa jednak navádí více k tomu, že testovat se má chování systému a ne jeho stav a taktéž se mi líbí ta kombinace: systém má dělat XY (pokud to failne, tak je ze jména čitelné systém nedělá XY) … ale uznávám, že když si člověk dává pozor i s prefixem test se dají metody pojmenovávat správně, jen ten prefix should je více podvědomně návodný

    • Hi Dagi,

      thanks God our languages are similar so I think I was able to understand what you wrote. 🙂

      „Should“ is not a magic bullet. By using it you do not make your tests good. This is obvious.
      „Test“ is not evil. You can write good tests using this word. This is also obvious.

      However, what I observe, and what I tried to explain during the talk, that using „should“, or rather, that following the naming pattern which promotes prefixing the test method name with „should“ and then explaining both the situation and the expected result, results in much better, focused and easier to understand tests. (wow, that was quite a sentence, wasn’t it?)

      In other words, I believe it is much harder to write a bad tests under the name of „shouldRejectRequestWithInvalidHeader“ than to write a bad test method called „testRequest“. Because the first name tells you exactly what is the purpose of this test, and helps to concentrate on it.

      Cheers!